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1 Introduction
Computers were originally designed for numerical computational tasks and
despite current popular usage in text processing, that is still what they are
best at. They are particularly good at boring, repetitive and laborious
calculations, and that is what much statistical work consists of. For many
years people have produced programs for PCs and mainframes that perform
these long and complicated statistics calculations on sets of data. Most of
these programs have required you to learn a command language in order to
perform the calculations. In addition, these statistics packages required you
to flip between at least three files in turn – your data file, your command file
and your output file. This has felt very clumsy.

SPSS for Windows is one of a new breed of statistical software which takes
advantage of the Microsoft Windows (MS Windows) graphical environment.
The aim of the product is to make statistics as straightforward and easy a
task to accomplish on computer as possible. The MS Windows environment
enables you to see multiple files open at once. The menu system enables you
to build up complex statistical commands quickly and easily using a ‘point
and shoot’ method, without necessarily involving detailed knowledge of the
command language.

Aim of this Document

This document is designed to introduce you to the SPSS for Windows
interface. From the information in this document you should be able to open
SPSS for Windows, find your way around the interface and use the Help
system. You should also be able to enter data, save files, print files and learn
the basics of performing statistical analyses.

The document is intended for anyone wanting to use SPSS in the MS
Windows environment. It is assumed that you already know how to login to
the Novell network, start MS Windows and perform basic MS Windows
operations with the mouse. No prior knowledge of SPSS is assumed. The
example sheet used for the illustrations in Section 6 is called BANK.SAV and
can be found in the directory L:\WINAPPS\SPSWIN61 on all Novell servers.

If you are using, or intending to use, SPSS for Windows on your own PC you
will also find this document useful. If you want to obtain a copy of the
software to run on your own PC you should contact the Help Desk in the ISS.
The Help Desk sell copies of the software, and provide details on how to
install the software and the terms of the SPSS site licence.
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2 What is SPSS for Windows?
Before the Windows version was written, SPSS was used on a variety of
computer systems including CMS, UNIX and the MS DOS operating system.
This document is designed for use with versions 8.0 and 9.0 of SPSS for
Windows.

The History of SPSS

SPSS has long been one of the most popular statistical analysis packages
amongst academics in Britain. Originally it was designed for the analysis of
Social Science data, but it has developed into a general statistical analysis
system for all types of data. Leeds first purchased SPSS for the ICL 1906A in
the early 1970s, then obtained it for the Amdahl computer and it appeared
on the PC as SPSS/PC+ in about 1986. Now with the trend in the computing
world towards windows environments, SPSS has been one of the first
companies to release an MS Windows version of a statistics package.

The advantages of running SPSS under MS Windows are enormous. Firstly,
the ability to have more than one file open at once means that SPSS users
can see their data file alongside their command file and their output file. This
greatly facilitates error correcting when writing long and sometimes complex
command files. It also helps analysis where you can check the results of an
analysis against the raw data.

Secondly, the system of menus and dialog boxes which drives all MS
Windows applications enables statistical analysis to be done, not by learning
a command language and typing it in, but by selecting your analysis from a
list of options. In this way you are freed from the mechanics of how to
perform the analysis and are left to think about the analysis you want to
perform and what it means.

Thirdly, the graphical nature of MS Windows means that SPSS have now
included an excellent graphics module, enabling users to view the results of
analyses with pie charts, column charts, histograms and scatter plots. With
the ability to plot graphs in 3 dimensions you can even perform a cluster
analysis by rotating data on one of the three axes and lining the points up by
eye.

Finally, statistics are never produced in a vacuum, but are always for
presentation to others. The MS Windows environment facilitates the easy
transfer of data, results and graphs from SPSS into other applications,
especially word-processing applications. SPSS supports many types of data
transfer from basic cut, copy and paste to full DDE 1 and OLE 2 compliance.
SPSS is also able to save data in a variety of file formats in case you want to
use another package to present or analyse it. Particularly, SPSS will read and
write Excel v4 and Lotus v2 spreadsheet files.

                                             

1 DDE - Dynamic Data Exchange. A method of automatically accessing data from other
computer packages.

2 OLE - Object Linking and Embedding. A method whereby other applications are called
automatically to edit pasted objects.
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3 Starting SPSS for Windows
To start SPSS you need to be logged on to the Novell network and running
MS Windows NT (at least version 4.0 of NT is needed for SPSS version 9.0).

Memory Limitation

Before you start to run SPSS you will need to
make sure that the machine you are using has
enough memory to run it. SPSS is a large
program, and the latest version requires a
minimum of 8Mb RAM in order to run. If you
are uncertain whether the machine you are
currently sitting at has enough memory, go to
the Help menu in Windows NT Explorer and
select About Windows NT as shown in Figure 1.
The box shown in Figure 2 is then displayed.

Figure 2  The About Windows NT information box.

If the number to the right of Memory Available to Windows NT: (near the
bottom of Figure 2) is less than 8,192 KB you will not be able to run SPSS. In
this instance you will need to find a computer that does have the memory
you require. There should be a notice on the cluster notice board informing
you of which machines have 8Mb on them.

Running SPSS

To run the SPSS program, position the mouse cursor over the SPSS icon, and
press the left hand mouse button twice quickly.3

                                             

3 On Novell systems the SPSS icon will normally be in the Statistics group.

Figure 1  The Windows NT
Explorer Help menu
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4 The Opening Display
SPSS may take a minute or so to load, but once it has done so your screen
should look the one below. If this window does not appear you should go
straight into the Data Editor window shown in Figure 4 instead.

Figure 3  The opening SPSS Screen for versions 8.0 and 9.0

Select the appropriate radio button, for now select Type in data, and click
<OK>. You should now be able to see the Data Editor window.

The Data Editor Window

The SPSS interface follows many MS Windows conventions that users of
other MS Windows programs will be familiar with. The Data Editor contains a
title bar, a collection of menus, a toolbar and a status bar. Figure 4 shows the
Data Editor in version 8.0 of SPSS (version 9.0 is only slightly different).

In structure it looks very like a spreadsheet, such as Excel, but in practice it
operates in a very different way. This window is where you enter, edit, view,
transform and label the data that you want to analyse. Each column of the
grid represents a single variable, and each row in the grid represents a single
observation or case. The data window is unique among all the SPSS windows
in that it is the only window which you can only have one of open at any one
time.

It is important that you realise the differences between the SPSS data sheet
and an Excel spreadsheet. In the SPSS data sheet the structure of the rows
and columns is important and rigid. Columns are always variables, rows are
always observations. In a spreadsheet you have the flexibility to change this
around. Also, calculations are set up in different ways. With SPSS you use
one or more variables in a calculation to produce another variable, so



5

calculations are done literally column by column. In Excel you can use two
individual cells for calculations, and then cascade the calculations into other
cells or groups of cells as you want. Also, in spreadsheets the cells can store
the formula and recalculate the result if the original data changes. SPSS only
stores values, so if the value of a source variable changes you will have to
repeat the calculation.

SPSS data is stored in a data file. This is equivalent to what used to be called
the SPSS System File. The default file extension for data sheet files is .SAV.
You can read data in to the SPSS data sheet from a variety of sources, the
most significant of which are SPSS portable files, Excel spreadsheets, Lotus
1-2-3 spreadsheets and text files.

Figure 4  The Data Editor window for version 8.0

Menus

SPSS has ten main menus available when you are viewing the Data Editor
window. Version 9.0 has a menu labelled Analyze instead of Statistics. The
list of menu options changes when you are in different windows. The menus
follow the standard Windows format of having the File and Edit menus to the
left hand side of the screen, and the Window and Help menus on the right.
The menus found in the Data Editor window are described in more detail
below:
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File

The File menu deals with all the file-handling
aspects of SPSS. If you want to open an
existing file, open a new file, save a file or
print a file, the commands are all here.
Version 9.0 has a Read Text Data option to
replace Read ASCII Data.

Also included is an Apply Data Dictionary
command that stores information about your
data. This is especially useful if you have
received data from elsewhere and you need to
know what it is about and how it is organised.

Finally the command to exit from SPSS when
you have finished is here.

Edit

The Edit menu also shares much in common
with other Microsoft Windows applications.
This menu contains commands for undoing
the last action, cut, copy and paste actions,
and the command for find. Also in this menu
is the Options command so that you can alter
your own SPSS set up.

View

The View menu alters some of the display
attributes, such as whether grid lines are
displayed and whether value labels are
displayed instead of the codes. The chosen
commands are marked with a tick.

Data

The Data menu is used to make global
changes to SPSS data files, such as merging
files, transposing variables and cases, or
creating subsets of cases for analysis. You
can insert new variables and new cases, or
you can sort your cases according to a
particular variable, transpose the cases or
weight the cases. These changes are
temporary unless you specifically save the
file with the changes. The Orthogonal Design
option is no longer in the Data menu in
version 9.0.

Figure 5  The File Menu
in the Data Editor window

Figure 6  The Edit Menu in
the Data Editor window

Figure 7  The View Menu in
the Data Editor window

Figure 8  The Data Menu in
the Data Editor window
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Transform

The Transform menu is used to make changes
to selected variables in the data file and to
compute new variables based on the values of
existing ones. Random numbers can be
generated and ranking or recoding of data can
also be done. Changes are only temporary
unless you specifically save the data file.
Version 9.0 has the extra choice of
categorising variables from discrete values to
categories, this is done using Recode in
version 8.0.

Statistics

The Statistics menu (Analyze in version 9.0)
contains the ‘meat’ of the package. It contains
all the categories of statistics that SPSS is
capable of performing. The little arrows to the
right of all the menu options indicate that
there is a submenu of more specific tests or
groups of tests. The submenus are too
detailed to go into here. This menu is slightly
different in version 9.0. The Summarize option
is split into Reports and Descriptive Statistics
but the total content remains almost the
same.

Graphs

The Graph menu enables you to plot graphs
from the data. Some of these graphs can also
be plotted as part of a wider analysis. SPSS
supports the five main chart types − Bar (or
Column), Line, Area, Pie and High-Low. It can
also produce real histograms, quality control
graphs, scatter plots in up to 3 dimensions,
and several other specialist graph types
(version 9.0 can also produce an ROC curve).
One extra graph SPSS supports is the
Boxplot, used mainly in non-parametric
analysis, or when you want to get a feel for
the shape of a small quantity of data.

Figure 9  The Transform Menu
in the Data Editor window

Figure 10  The Statistics Menu
in the Data Editor window

Figure 11  The Graph Menu in
the Data Editor window
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Utilities

The word ‘Utilities’ in menus often means
‘Miscellaneous’ − which means that this menu
collects all the commands that did not fit
comfortably anywhere else. The Utilities menu
houses a list of variables currently available
from the data sheet, it allows you to define
sets of variables which need to be analysed
together. Finally the Utilities menu allows you
to run a script or change the menus using the
menu editor.

Window

The Window menu is found in many MS
Windows programs, and it is simply a series of
commands to let you select and resize the
other windows used in SPSS. Most of the
commands here can be done with the mouse.

Help

This menu contains the commands for the SPSS Help system. The Help
system is described in more detail later.

Other SPSS Windows

The total number of other windows you can have open is limited only by your
computer’s system resources (except for the Data Editor window where only
one is allowed to be open at any one time), but their types fall into five
categories. When you first open SPSS, two of the windows are usually opened
automatically for you – the Data Editor window and the Output window. If the
Output window does not open immediately it will do so when an analysis or
chart is requested. The other windows you will have to request specifically,
either by double clicking on a chart in the Output window (this produces the
Chart Editor window) or by opening a new or existing command file
(producing the Syntax window or the Script window).

Output Window

The Output window is where SPSS stores the results and charts from all of
the analyses you have performed. This window can be saved with the
extension .SPO. You are not expected to enter information into this window
manually, but you can edit the contents if you want.

Syntax Window

The Syntax window is a straightforward text window, the purpose of which is
for you to type in SPSS commands to analyse the data set. Many users will
not want to learn SPSS commands, and some may not need to, but there are
certain analyses which SPSS will only do through the command language.

The Toolbars

Underneath the menu bar is a toolbar that contains shortcut buttons to the
most common commands. The buttons available on the toolbar depend on
which window you have active at the time.

Figure 12  The Utilities Menu
in the Data Editor window

Figure 13   The Window Menu in
the Data Editor window
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Figure 14  The Data Editor toolbar

If you move the mouse cursor over the buttons in the toolbar then their
functions will appear in the status bar at the bottom. The main button
functions are described below.

 File Buttons

The first three buttons give the three most common commands from the File
menu – Open an Existing File, Save the Current File and Print the Current File
respectively.

Dialog Recall

This button gives you immediate access to the last 12 dialog boxes you were
working with. This is extremely useful if you are building up an analysis and
constantly going back to the same box to change or modify an option.

Goto Chart

This button allows you to go to an open Chart Editor.

Goto Data

When in a window other than the Data Editor window this button will return
you to the Data Editor.

Goto Case

This button allows you to go directly to a specific case in the data editor. It is
useful if you need to edit your data, or if something unusual has cropped up
in your analysis and you want to check out the source data.

Variables

Clicking on this button produces a dialog box containing a list of all the
variables defined in the data file. Selecting a variable from this list displays
the variables properties - its name, label, type, information about missing
values and the value labels. This box can be kept open whilst you work with
the data file so that you can examine a variable's information as you examine
the results of an analysis.

Find

This button allows you to perform a simple search to find a value.

Insert Case / Insert Variable

Data entry, being the tedious exercise that it is, is fraught with errors.
Consequently it is not unusual to find yourself wanting to add a case or a
variable in the middle of ones already created. These two buttons will add a
blank row or column in your dataset to allow you to do that.

Split File/Weight Cases/Select Cases

These buttons allow you to do three of the Data menu commands with ease.
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Value Labels

In SPSS you can create meaningful labels for non-meaningful numerical
data. This button allows you to display the labels in the data editor so that
you don’t have to remember what the numbers meant.

Use Sets

In SPSS you can group variables together into sets so that the variables can
be analysed together. This button allows you to specify what sets of the ones
you have defined you want to use.

Designate Window Button

SPSS allows you to have more than one Output or Syntax window open at
any one time so that the results you create can be shuffled into different files.
This begs the question of how SPSS knows which file you want the results to
go to. The answer is that, for example, one of the Output windows has to be
the Designated Window. This is indicated by an exclamation mark (!) in the
title bar of the window. If you want an Output or Syntax window to become
the designated window, make it the active window and click this button on
the toolbar.

Note The Designated Window is not the same as the Active Window. The Active
Window is the window at the forefront of your screen. Anything you type, or
any menus you use should happen in the Active window. Of all the windows
you have open on your desktop, only one will be the Active Window. The term
Designated Window only applies to Output and Syntax windows which act as
a destination for SPSS produced text. There is one designated Output window
at any one point in time plus one designated Syntax window.

Run Commands

This button allows you to run commands from the Syntax window. SPSS will
begin from the start of the command where the insertion point currently is,
and go through the commands until it finishes.
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Chart Editor Window

If you want to edit a chart, double-click on it twice and it will open up in the
Chart Editor window.

Figure 15  SPSS with The Chart Editor window

Notice that the menus have changed again, and so has the toolbar. In the
Chart Editor you can tailor your charts to suit your needs. The main menus –
File, Edit, View, Statistics/Analyze, Graphs and Help – have stayed exactly the
same, but now there are new menus of Gallery, Chart, Series and Format. The
new menus are briefly described here.

Gallery

This menu lets you choose the sort of chart to display. The menu is a cut-
down version of the Graph menu described earlier.

Chart

This menu allows you to add and alter the
peripheral bits of a chart, such as the title, legend
and other sorts of annotation.

Figure 16  The Chart menu
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Series

This menu lets you alter the way the series is displayed, including the
omission of certain values, and lets you transpose data directly on the graph.

Format

This menu alters just about everything else on
the graph itself – the colours, the font types and
sizes, the style of graph and the perspective. It
also allows you to add in an interpolation or
regression line through a set of points.

The toolbar has also changed so that it contains
the base tools already described plus tools
specific to working with charts. These tools are
actually button shortcuts for commands in the
Attribute menu. They are:

Fill pattern

Colour palette

Marker style

Line style

Bar style

Bar labels

Interpolation

Font type and size

Swap axes

    3D rotation

Explode slice (of a pie
chart)

Break line for missing
values

Chart options

Spin mode. Using this
mode you can rotate a
3-D scattergram on any
of its three axes.
Clicking this button will
in itself produce
another toolbar, but
that is beyond the scope
of this document.

Figure 17  The Format menu
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5 The Help System
Usually it is not necessary to describe a program’s Help system. If the Help
system needs to be described so that people can use it then it indicates that
it isn’t very good. The Help System for SPSS does not need describing, but it
is so good that an overview of what’s available should be informative.

SPSS has an extremely thorough Help system. The Topics section allows you
to choose from a contents list or an index, or run a search for a topic. The
Tutorial section is good for the first-time user for a general overview (see
later). Option SPSS Home Page will open a web browser at the
manufacturer’s home page. The Statistics Coach is designed to help you find
the best way of achieving the analysis you want. The About command simply
displays information about the release date and version of SPSS.

Context-sensitive help is also always available either from the Toolbar or from
a Help button in dialog boxes.

Version 9.0 also has a useful Syntax Guide in the Help menu.

The Tutorial

SPSS have written a simple introductory tutorial that will take you through
the basics of using SPSS for Windows and introduce you to the major
concepts involved. It is strongly recommended that if you are new to SPSS
you go through the Tutorial before you attempt to do anything else with the
program – it could save you a lot of time later!

Selecting the Tutorial option from the Help menu brings up the following
window:

Figure 18 Tutorial screen
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There are many sections to the Tutorial that go through different aspects of
using SPSS, including entering and editing data, performing an analysis,
creating and editing charts, and getting help whilst you work.

The Index

For the experienced and the novice user the Index section provides
explanations of a wide range of terms, including what all the statistical tests
are, when they are used and what the results mean. For people who are
uncertain on their statistical knowledge this section could be very useful.

Figure 19  An example of the Index Help system

Syntax Diagrams

The experienced user who starts to write their own SPSS language
commands directly into a Syntax window will benefit from the using the Help
Index to find syntax commands. The resulting information gives a description
of what the command does and a syntax diagram explaining how to write the
command correctly. Having this help screen open alongside your Syntax
window will prove invaluable for many people.

Figure 20  An example of the Syntax window

The fact that the Help System is so comprehensive means that it is possible
to get started on SPSS without using a manual, although serious users are
strongly recommended to obtain a manual if they can. If you cannot, or
would rather not, purchase a manual then you can print out Topics in the
Help system for reference and bed-time reading.
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6 Using SPSS for Windows
Aim

This section goes through some of the common actions you might want to do
in your first session with SPSS. It is not designed as a step-by-step tutorial,
but merely as a pointer on how to accomplish certain tasks. For the
examples, a data sheet called BANK.SAV is used, which is located in the
\WINAPPS\SPSWIN61 directory on the L: drive on the Novell network.

Entering Data into a Blank Datasheet

In a blank data sheet, along the top all the columns are labelled var in light
grey, and down the left-hand side all the rows are labelled 1, 2, 3, ... in
light grey. The light grey indicates that there is nothing in the rows or
columns yet. There should be a dark border around the cell in the top left
hand corner. This dark border is called the cell highlight and it highlights the
active cell. The active cell is where any numbers or text that you type will
appear.

Type the number 1. The number 1 appears in a line above the grid of cells,
called the data line. Now press <Enter>. The number appears in the cell. Also
the number 1 on the left changes from light grey to black, and the word var
at the top of the first column changes to var00001 in black. This indicates
that row one (the first observation) has some data, and that column one (the
first variable) has some data. Also, the cell highlight is now on the cell below
the one containing the number 1. Continue entering numbers, following each
number by pressing the <Enter> key.

2 <Enter>, 3 <Enter>, 4 <Enter>, 5 <Enter>

Using either the arrow keys on the keyboard, or clicking with the mouse,
select the first cell at the top of the second column. Now type the number 1
again and press <Enter>. Once again the greyed-out word var at the top of
the column changes to black and becomes var00002, indicating that a
second variable has now been created. However, if you look carefully in the
cells 2-5 in the second column you will see that they contain full stops. In
SPSS the full stop, or period, represents a ‘missing value’. There is no such
thing as an empty cell in SPSS. Values either exist for each variable and
case, or else they are missing. Fill in the rest of the numbers as before:

4 <Enter>, 9 <Enter>, 16 <Enter>, 25 <Enter>

Naming Variables

The names that SPSS automatically gives to your variables are not terribly
informative, so it makes sense to rename them. To do this, move the cursor
over the variable name you want to alter at the top of its column, and double
click the mouse button. Alternatively select the Define Variable command
from the Data menu. A dialog box appears in which you can type your new
variable name. The box also has a number of options for labelling your
variable, and formatting the way the numbers will appear in the data sheet.
Fill in the boxes as you want them and then click the <OK> button.
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Figure 21  The Define Variables dialog box

Saving an SPSS File

To save the data sheet to a file, select the command File Save As.... A dialog
box appears in which you select the drive and directory you want to save the
file to, the name of the file you want to create, and also the file format of the
file you want to create. This is especially useful if you want to transfer your
data to other applications.

Figure 22  The Save As dialog box
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Opening an Existing File

From the File menu select the command Open. Different file types have
different formats and extension names, so it is important for SPSS to know
what file type it is opening. Select the file type you want using the mouse
(.sav, .spo, .sys, .sbs). A dialog box appears listing all the files of that
type in the current directory. Change directory using the drop down box Look
in: Once you have found the file, select it and click on <Open>. The file opens,
but any data file you were previously working on is closed.

Figure 23  The Open File dialog box

Performing a Simple Analysis

With a loaded file in the data sheet, select the Statistics menu (or Analyze in
version 9.0 of SPSS). This gives you the list of options of statistical analysis
that you can perform. Select the Summarize.. statistics (or Descriptive
Statistics in version 9.0 of SPSS). A submenu appears with a list of the
summary statistics you can perform with SPSS. If you select Frequencies, a
dialog box appears giving you options for your frequency statistics.

Figure 24  The Frequencies dialog box

The first job is to select the variables you want to work with. This is done by
selecting them from the column on the left-hand side, and pressing the arrow
button to ‘transfer them across’ to the list of variables to be analysed. Once
this has been done you could just click <OK> and the default frequency
analysis would go ahead. Alternatively, click on one of the buttons at the
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bottom of the dialog box. These each bring up another dialog box in which
you can add to the statistics which are calculated. You can also ask SPSS to
plot graphs here.

When you have tailored the analysis to your needs, click the <OK> buttons.
The analysis starts off, and the progress of what commands are being run is
shown on the status bar at the bottom left hand corner of the main window.
The Output window is moved to the front and the results of the analyses are
placed there for you to view.

Plotting Graphs

Start with the Data Sheet being the active window
at the front of the screen. Select the Graph
command. From the list of graph types available
you select the one you want – try a bar chart. Do
not worry about being too precise at this point
because you can always change the format of the
graph at a later stage.

A dialog box appears asking you what sort of
graph within the type you have chosen you want
(see Figure 25). Choose one and click on <Define>.

A second dialog box appears for you to choose the
variables you want plotted.

Figure 26  Bar Chart dialog box

Select the variables you want to plot in the same way as you select the
variables you want to analyse by clicking on the variable and then clicking on
the button next to the box labelled Category Axis: At this stage you can also
add a title to your graph and alter other plotting options. When you are
ready, click the <OK> button. The graph is plotted and placed in the Output
window.

If after preparing your analysis dialog box, or your graph box, you click the
<Paste> button instead of the <OK> button, an SPSS command performing
exactly the same action is pasted into the designated Syntax window. If no
Syntax window is open a new one is created. The command is not run but is

Figure 25  The Define
dialog box
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left in the Syntax window for you to edit and run later. In this way you can
build up your own command files by creating them via the menus and dialog
boxes.

Printing Files

Have the window of the data you want to print as the active window, and the
data highlighted, and choose Print from the File menu. If you have set up a
printer in the control panel correctly your file should print without problem.
You should consult the document Getting Started on Microsoft Windows on the
PC (BEG 2) for more details.
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7 General Comments
The Command Language

It is recommended that everyone who uses SPSS, except on a casual or
occasional basis, should be familiar with the basics of the SPSS command
language. Not only will this give you a greater understanding of how the
SPSS system works, and therefore how best to use it to suit your needs, but
it will enable you to do more precise and complicated analyses than are
possible by just using the menus and dialog boxes. For certain analyses it
may also be quicker.

The command language in SPSS is notorious in that no two versions of it are
exactly the same. The essential commands and syntax are the same, but
there are minor differences that you will have to watch out for. It is always
worth transferring your command files to see if they work, but if they do not
it may be better to rebuild them from scratch using the menus and dialog
boxes, and then pasting the commands into the Syntax window.

The two main things to watch out for when transferring command files to
SPSS for Windows from other versions is to make sure there is a full stop at
the end of every command and that a batch of commands has an EXECUTE
statement as its last command.

Transporting Data Between Different Versions of SPSS

Users wanting to move their SPSS work between SPSS for Windows and
other versions of SPSS (such as SPSS/PC+ or SPSS on the Sun GPS system)
are strongly advised to transfer their data either as an ordinary text file or as
an SPSS portable file. If you already have a permanent SPSS system file, the
latter option is probably the best one. The fact that the command language in
SPSS for Windows is subtly different from the command language in other
versions means you should not necessarily expect command files written in
other versions to run without problems.

Using SPSS with Spreadsheet Files

SPSS can read and write spreadsheet files in Excel or Lotus format. People
who already have data in a spreadsheet file can easily transfer it to SPSS for
detailed statistical analysis. However, if you are intending to transfer your
data from Excel or As-Easy-As to SPSS there are some points to watch:

• Your data should be organised into columns for the variables and
rows for the observations. If they are not, transform them in the
spreadsheet first.

• The main table of data should be in the top left-hand corner of the
spreadsheet. If it is not, you will probably have to delete a number of
columns and/or rows in the SPSS datasheet to remove unwanted
blank space.

• If you have put titles at the top of your data, SPSS will assume that
these are the variable names, and will make them so. SPSS may have
trouble if you have more than one row of titles.
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8 Documentation
The SPSS Incorporation produce their own manuals for SPSS for Windows
which can be purchased through the Help Desk. The manuals available are:

SPSS Base Users’ Guide
Essential for anyone using SPSS on a regular basis. Covers the use of
the interface, charts and basic statistics.

SPSS Base System Syntax Reference Guide
Required if you are going to be writing SPSS command files.

SPSS Regression Models (Professional Statistics for version 8.0
and below)
Covers Discriminant Analysis, Factor Analysis, Cluster Analysis,
Reliability Analysis and Multidimensional Scaling. The manual covers
the use of both the Menus/Dialog boxes method, and the command
language syntax for these type of analysis.

SPSS Advanced Models (Advanced Statistics for version 8.0 and
below)
Covers more advanced Regression and Analysis of Variance
procedures. Includes Logistic Regression, Loglinear Models, Nonlinear
Regression, Cox Regression, Factorial Analysis of Variance, Multivariate
Analysis of Variance, Repeated Measures Analysis of Variance, Probit
Analysis, Life Tables and Kaplan-Meier Survival Analysis.

SPSS Tables
Covers procedures for calculating and presenting tables of data and the
results of analysis.

SPSS Trends
Covers Time Series Analysis, Exponential Smoothing, Regression
Forecasting and ARIMA Models.

SPSS Categories
Covers Optimal Scaling.

SPSS Conjoint Analysis
Covers Conjoint Analysis (Conjoint is part of the Categories manual for
version 8.0 and below).

More SPSS manuals will become available as extra modules to the SPSS
system are released.


